Jacaranda: Chaiyut Jandaeng

May 2, 2010

การติดตั้ง contiki บน ubuntu 10.04

Filed under: Contiki — jacaran @ 7:51 pm

การติดตั้ง contiki บน ubuntu 10.04
หลังจากที่ ubuntu 10.04 lucid ได้แผยแพร่อย่างเป็นทางการ ผมจึงลองติดตั้งบน virtualbox แล้วลองติดตั้งโปรแกรม contiki ซึ่งใช้ในวิทยานิพนธ์ ผลปรากฏว่า ได้รับผลกระทบเช่นเคยครับ ในขณะที่ ns-2.34 นั้นสามารถใช้การได้ แต่ยังติดปัญหาเรื่องของ gcc นั่นแหละครับ ทางแก้นั้นยังแก้วิธีการเดิมครับ สำหรับ contiki นั้นได้รับผลกระทบทางด้านของ gtk เพราะโปรแกรมเดิมที่ใช้นั้นใช้ gtk-1.2 แต่เวอร์ชันบน lucid นั้นเป็น gtk2.0 ครับ ในขณะที่ติดตั้งนั้นตัวแปรภาษาต้่องการ gtk-config ซึ่งมีอยู่ใน gtk 1.2 แต่ไม่มีแล้วใน gtk2.0 ทางออกที่ใช้การได้คือให้ติดตั้ง gtk1.2 ควบคู่ด้วยครับ

1. download contiki 2.4 จากเว็บไซตน์ต้นตำหรับไว้ที่ home directory
2. ติดตั้งโปรแกรมกลุ่มนี้ก่อนใช้งาน contiki

MSP-430 Tool-chain
1. แก้ไข sources-list
$ sudo gedit /etc/apt/sources.list
add

deb http://tinyos.stanford.edu/tinyos/dists/ubuntu lucid main

$ sudo apt-get update

2. ติดตั้ง package ที่เกี่ยวข้องครับ
$ sudo apt-get install msp430-binutils-tinyos msp430-gcc-tinyos msp430-libc-tinyos

libgtk1.2-dev
1. แก้ไข sources-list
$ sudo gedit /etc/apt/sources.list
add
deb ftp://ftp.psu.ac.th/pub/ubuntu/ jaunty main multiverse restricted universe

$ sudo apt-get update

2. ติดตั้ง package ที่เกี่ยวข้องครับ

$ sudo apt-get install libgtk1.2-dev

3. extract file ด้วยโปรแกรม unzip
$ cd ~
$ unzip contiki-2.4.zip
$ cd contiki-2.4/examples/hello-world
$ make TARGET=sky # in order to test tmote sky platform
$ make TARGET=netsim # in order to test netsim ( simulation)

Advertisements

Create a free website or blog at WordPress.com.